news

New Christian's Rom 5.419

Rss feed for topic Xperia RomXperia Rom - Posted by: christian On 27-05-2010 @ 01:06

New rom 5.419 based on 23569 online

The new rom is finally online. Here's the changelog again:

- new sys: 23569(Branche: COM5)(Timebomb fixed):
- X2 R3AA035 stuff updated
- Panel manager updated to 2.2.20.0
- flashpanelandMMIIInstall updated(seems like atleast the flash panels postions are fixed now)
- updated xkeyhandler
- updated xpfilterdeploy
- updated xpframework
- updated tilewave panel
- SPB Mobile Shell 3.5.1 panel from x2(even in dutch on dutch roms)

Have fun, more mirrors and clean rom soon but i'm quite busy at the moment


Comments:

Peter
27-05-2010 - 01:08

Hmm, zal ik het nog doen, of toch eerst maar gaan slapen....

Christian
27-05-2010 - 01:10

Ikzelf ga nog een paar mirrors online zetten van de full en dan ook maar slapen 't is al laat dusja

Peter
27-05-2010 - 01:59

I just couldn't let it go! Downloaded, installed and ready. Internet active, Google sync working. So I can use it tomorrow ;-) No further testing done yet. Thanks Christian for another ROM!!!

Yalanse
27-05-2010 - 07:16

Downloading~ :-)

Ivan
27-05-2010 - 11:21

Hi, can you tell how to play music using Tilewave Panel, please? When I click the button, there is nothing happened. Do I have to place music file to any specific folder? Thanks

Burrn
27-05-2010 - 11:59

Christian
27-05-2010 - 12:51

@ivan, burrn: Don't think it is possible at the moment. Seems like some dependencies are missing but I couldn't find out which one(atleast for now). I'm to busy at the moment for further developing on the rom so it has to wait a bit that's why I released this rom like I got it running on my own phone for the last weeks. I think some slideview files are missing or something will look into that later

Michelle
27-05-2010 - 13:06

I tried installing your ROM on my HTC HD and it keeps saying invalid model ID. Can you give me some advice? Every other ROM seems to work. Thanks.

Christian
27-05-2010 - 13:24

I guess the error code says enough: it's just for the x1 not for any other phone, sorry

Roger
27-05-2010 - 14:03

Roger
27-05-2010 - 17:52

ok hij werkt nu!! ben even terug gegaan naar een stock rom en van daar uit naar jou nieuwste!! :) die is echt mooi geworden! good job!:)

stanny
27-05-2010 - 19:08

het installeren van de ROM gaat zonder problemen, maar eens opgestart en HTC sense actief is, dan krijg ik niets meer geopend... alles sluit vanzichzelf. Is precies of sense niets meer toelaat, zelfs het startmenu sluit onmiddelijk terug...

Chris
28-05-2010 - 04:27

Thanks for your excellent work on these ROMs.

Leo
28-05-2010 - 06:13

Hi Christian, I installed this latest ROM and everything is good, the only two problems I noticed is that the tilewave panel still has no words in the settings screen and the media panel lack all word descriptions. Besides that all runs well. Thanks for your hard work.

Christiaan
28-05-2010 - 10:48

Hi Christian, Thanx for the new update. Looks great. I just discovered a bug. I use the SPB Mobile Shell. When I click on the contactlist button (third button from the left at the bottom), the window with speeddials opens. When I click on the address book in this window, nothing happens. Ever since the first ROM I used from you I experience a problem with the data connection. When I switch the data connection on in the Comm Manager, an error is displayed (connection can't be established). I have to go into "Bewerk bestaande verbinding", click next, next, next, next, ..., finish (don't change anything). After doing this, data connection works fine until connection is lost for some reason (going into underground parking lot). This is very inconvenient. Do you know how to solve this? I already tried to to flash stock ROM first before flashing your ROM 5.419. Regards, Christiaan

Christian
28-05-2010 - 11:50

@leo: What do you mean lackall word description? Like an empty media panel? What rom version do you use? @christiaan: I can't do anything about the button since spb mobile shell is like it has been released by SE. So it's up to them to fix this. For the data connection. I will look into a newer connection setup maybe that will fix the connection problems for some users.

Christiaan
28-05-2010 - 11:53

Unfortunately I found another bug. In ActiveSync I entered my gmail settings (IMAP). In Outlook E-mail I can't select the "Spam" folder anymore, I only have the "All Mail" folder under [Gmail]. When I select the "All Mail" folder, the headers of the emails are visible; however a nice white screen is shown when I select an e-mail at the location where the text should be. Regards, Christiaan

Yalanse
28-05-2010 - 12:31

Christiaan, maybe you need a hard reset, since I don't experience this problems. Except email, cause I don't use G-mail.

Peter Hoogstraaten
28-05-2010 - 14:18

Hi Christian, Used the new ROM for a day now. Did not use the phone for calling, but internet and bluetooth are constantly on. What is surprising is that after 7 hours of use (and yes no charger ;-) ) my battery level is still 94%! My (and your) previous one was much worse. Weird, but no complaints..... (and yes I reflashed the previous ROM to see if battery life would change) Keep up the good work! It seems this one was worth the wait :-)

Burrn
28-05-2010 - 14:55

Burrn
28-05-2010 - 16:13

Christian
28-05-2010 - 16:39

@christiaan: I don't use gmail personally but should be fine. @burrn: geen probleem hier hoor, waar zie je dat precies dan?

Burrn
28-05-2010 - 18:45

Had het helemaal boven in het scherm, vlak onder de taakbalk. Maar ben nu van thema veranderd en weer terug en heb er nu geen last meer van. Dus dat scheelt weer :)

Christiaan
30-05-2010 - 14:41

My problem with Gmail is solved by formatting internal memory with Task 29 and reflashing your latest ROM. Data connection is more stable as well. Hopefully SE solves the problem with SPB mobile shell soon.

Burrn
30-05-2010 - 14:53

Christian, deze ROM werkt echt geweldig. Bedankt! Heb nog wel een vraagje. Ik ben laatst naar een stock rom gegaan en heb hem met Task29 geformatteerd, moet ik nu ook nog even een nieuwe Radio rom flashen?

CTCNetwork
30-05-2010 - 17:21

Hi, Had had this installed a couple of days now. Is it me or does the new SPB shell hide messages in a thread? Seems to me that all the received messages, bar the latest no longer show when accessing SMS in SPB shell.. CTC...

Jaap
30-05-2010 - 18:46

De ROM ziet er goed uit, heeft soms nog wel last van vastlopers, maar de grootste ergenis, de Camera werkt niet..

Jaap
30-05-2010 - 18:53

Heb het overigens opgelost door XperiaCamera R3 (R27-35059)te instaleren, dus mocht nog meer mensen hier in de toekomst last van hebben.. :)

Christian
30-05-2010 - 19:31

@christiaan: mooi dat het opgelost is. @burrn: task29 haalt de radio niet weg alleen de rom files. Dus niet nodig om opnieuw een radio te flashen. @ctc: Don't know could be possible but I haven't seen it yet. But shouldn't really be a problem since you can see in the topbar if you have a new message. @jaap: camera werkt goed hier. Maar mooi dat het opgelost is

Drex
30-05-2010 - 21:29

Thanks for the ROM Christian. Everything works fine on my phone. One question though, Microsoft My Phone, does not work anymore even before this ROM release. Any idea why? Drex

Christian
30-05-2010 - 22:20

It's working fine for me, what rom language/version do you use? Try to download from marketplace again that should fix the issue

Christian
30-05-2010 - 22:25

I checked my myphone package and it seems that there is something wrong with the package. The english files are missing so I've fixed it and in the next rom it will work fine!

Leo
31-05-2010 - 00:55

Hi Christian, My media panel is as follows: it shows only the picture icon and the word under the icon is missing. I can scroll and select the icon but I don't see the word. Should I do a soft reset? it seems like no one else has this problem. Thanks

Jeffrey
31-05-2010 - 07:53

Gebruik je nieuwe Rom nu een paar dagen en ik denk dat dit toch wel m'n laatste update is geweest... deze werkt echt super goed, in 4 dagen maar 1 vast loper gehad. en dat was toen ik facebook wilde openen (maar dat gebruik ik toch nooit) SPB panel ziet er goed uit, Heel erg goed gedaan !

Stay-C
31-05-2010 - 10:01

He Christian, mooi werk weer met die laatste 5.419! Ik heb nog geen vastlopers oid gehad, dus helemaal happy! Het enige wat bij mn X1 niet werkt is de nieuwe SPB panel. Het lijkt als of hij blijft na denken. Verder helemaal top! But uhh keep up the good work! Greetz

Sepehr
31-05-2010 - 12:39

HI, First my huge thanks to you christian for your roms, but now I have a big question about spb in your new rom,I just have life style and I don't lnpw how can I go to menu carousel because in last version we had another button except Start,so how about now?Is it remove ?

CTCNetwork
31-05-2010 - 14:06

Hi, For Sepehr: I think you now only have either 3 or 5 screens - but no carousel. The number of screens is set in the options/settings for SPB and to change your screen you side swipe either left or right. Give side swiping a go and see how it works. Works in portrait and landscape.. CTC...

willem
01-06-2010 - 12:19

in het begin vond ik de deze release ook mooi Christian's Rom 5.419 maar ik wilde mijn eigen moblile shell 3.5.4 maar dan breek de hel los , dan valt er niks meer te doen met deze rom vast lopers en niks meer me te doen zowel op de clean als de full nl versie , dus maar weer terug naar 5.310 Full 23568 NL en daar draait alles perfect .

Dick
02-06-2010 - 20:14

De nieuwe versie werkt prima (5.419). Bedankt voor het goede werk! Ik ben wat items tegengekomen die ik met jullie allen wil delen. Het gaat overigens niet over Christian's software, deze is goed. 1. Ik ben begonnen met task29, om fresh te beginnen. Ik heb dit gedaan omdat ik punt 2 tm 3 tegenkwam en dat opgelost wilde hebben. Echter task29 was niet de oplossing. Na het draaien van tast29, bleef de X1 gedurende het opstarten in het 'sony ericsson' scherm staan. Hij starte niet door naar het bootloader-scherm. Keer op keer niet. Na lichte paniek heb ik dit opgelost door te resetten met alleen de 'vol-' knop ingedrukt. Daarna Christian's rom geinstalleerd. 2. Mijn Garmin software kreeg in niet meer opgestart, de oplossing is wat Christian al eerder aangeeft: In het programma 'AMeBa' onder het tabje 'position fix' de functie uitzetten. 3. Mijn Vodafone verbinding met GPRS en 3G werd niet tot stand gebracht of was instabiel. Ik heb dit opgelost door het toegangspunt te wijzigen in office.vodafone.nl i.p.v live.vodafone.com. Nu heb ik zo nu en dan toch nog problemen hiermee, maar meestal werkt het nu. Ik heb verder nog geinstalleerd: - OV9292 GPS - Adobe flashplayer - PHM RegEdit - SPB Traveler Nogmaals bedankt Christian!

Burrn
03-06-2010 - 12:01

Chester
04-06-2010 - 07:25

Hi guys need help to restore origanal firmware back onto my xperia x1i my slide does not work and it is still under warranty so i need to restore the firmware tried the sony website it says you have custom software cannot restore. please help. very sad to lose my custome software.

catacraciun
04-06-2010 - 13:54

@Chester you have to flash the StockSPL, instead of HardSPL. After that, just run Sony Ericsson Update Service. It will tell you that you have the latest firmware, so Select to install anyway ;)

Christian
04-06-2010 - 19:57

@stay-c: no problem here. @sepehr: I've also not seen the carousel. Not sure if it's even in this version. @ctc: maybe you're right. @willem: probeer even het panel eerst te verwijderen en daarna gewoon opnieuw jou versie installeren mischien geeft het problemen ofz anders.@dick: thnx for the tips. Btw die ov9292 is dat ook voor bussen? Zou wel handig voor mij persoonlijk zijn. Verder heb ik zelf geen problemen met vodafone werkt allemaal gewoon goed. @burrn: zou niet uit moeten maken maar zulke problemen zijn nooit terug te brengen naar 1 dinge eigenlijk dus we hopen maar het beste @chester: restore rom with stock rom and radio to stock radio. Then restore the spl and you will be fine. @catacracium: don't. Flashing the stock spl before the original rom and radio can brick your x1. Do it the way I described above and you should be fine.

Bokke Dijkstra
05-06-2010 - 17:22

Do not forget to install Hard-SPL before you flash the rom! Heb zojuist beide Roms gedownload...maar snap (nog) niet,wat met deze bovenstaandetekst wordt bedoeld. Heb de tekst gelezen in dit bestand,en zal deze z.s.m. installeren. Ziet er allemaal gelikt uit.... Prima Bokke

Christian
06-06-2010 - 16:56

Dat hard-spl geinstalleerd moet zijn om de rom te flashen op de telefoon

Ice
06-06-2010 - 23:19

hallo christian, Ik wil graag deze rom va je uitproberen maar heb een paar vragen/sugesties. Kan ik op het home screen ook mijn SPB diary toeveogen zodat ik al mijn afspraken gelijk kan zien voor die week? (zodat ik niet appart naar de agenda te gaan), en is het met deze rom mogelijk te smsen met een phone keypad waar je via het touchsreen nummerieke toetsen en ondersteuning van t9 gewoon kan typen zonder gebruik te maken van het toetsenbord?

Christian
07-06-2010 - 00:09

@ice: hiervoor moet je titanium uitzetten. En onscreen phone keyboard is via xda topic te downloaden. Ezinput heet het

Peter
11-06-2010 - 19:53

Hi Christian, after using this rom for two weeks one thing keeps coming back. (reflashing/stock and so on seems not to make a difference). When Sometimes when I select an sms the phone freezes. After a power cycle (battery remove) the same sms works fine. Later on when I have received new sms, sometimes it freezes again. I know.. guess you have no clue, based it happens 'sometimes' on a phone yopu do not see. But still wanted to let you know in case you hear it more often.

Peter
11-06-2010 - 20:19

Addition to previous post: Full NL Rom, no extra software installed except TomTom.

Burrn
12-06-2010 - 21:41

Same problem here as Peter. Phone sometimes freezes when I open an SMS or Email. Very Weird.

wesjeex3
13-06-2010 - 11:44

I got a request, can you make a ROM with Sense, only Sense. Something like agent_47's ROM or Energy Series. Regards

Christian
13-06-2010 - 14:49

@peter: When you got many sms messages from one contact the phone will almost freeze for some time. This is a wm 6.5 bug I guess since it's working fine in the beginning and after some weeks with messages its getting slow. My girlfriend got the same problem on her rhodium with agents rom. @wesjeex: I can but i'm not going to do that. You can enable sense as default over titanium

wesjeex3
13-06-2010 - 20:52

There were some rumors about Sense not fully working, is that still the case?

Drex
14-06-2010 - 22:40

I am receiving SMS messages but have not experience phone "freezing" opening these sms messages. Drex

catacraciun
15-06-2010 - 11:12

Hello Christian, I have a problem with SPB panel. I have installed a skin to lool like Sense, and, when I uninstalled this skin, when i open SPB panel, it displays "error". Could you give me the cab with SPB Panel 3.5? Thanks.

Christian
15-06-2010 - 12:29

@wes: it's because I didn't include all packages. This is to much and it only gives unneccessairy really big features. @drex: Me too, it's only getting a bit slow after some time @cata: It's in your windows folder;)

wesjeex3
15-06-2010 - 21:19

Ok, I'ma download it. :D

sjoerd
15-06-2010 - 23:15

ha Christian is weer een mooie rom draait erg lekker! maar is het ook mogelijk om een rom te maken met alleen de volledige sens 2.5?? mvg sjoerd

BeShO
16-06-2010 - 16:51

Hi Christian, first thank you for your lovely ROM i have been all around and you have the best ROM for X1. in this version, i cannot see the text on the media panel or the tilewave panels. the text is not showing at all. what could be the issue?

Christian
16-06-2010 - 18:52

@sjoerd: het is mogelijk maar ik ben dit niet van plan @besho: I'm aware of the text problem in the tilewave settings panel. But I don't know how to fix this. For the media panel, I haven't heard of that problem. It was working on previous WWE roms right?

BeShO
16-06-2010 - 23:22

I haven't seen the text problem on media panel before I will try to reflash

wesjeex3
17-06-2010 - 16:06

Uhh.. Christian? Mijn startmenu werkt soms niet, dan klik ik hem aan, dan zie ik hem 1 seconde en dan is die al weer weg.

sjoerd
17-06-2010 - 23:54

Same problemo as wesjeex3

Jay
22-06-2010 - 13:44

Hoi Christian! Als eerst wil ik jou bedanken voor jou gave ROM! Hij is echt super! Ik heb alleen een klein probleembje! Miscchien dat jij mij kan helpen:) Als ik op MSN aanmeld en door middel van TOUCH of knopjes door mijn MSN lijst wil scrollen STOTERT hij! (Late reactie)... Weet jij miscchien waar het aan ligt? Alvast bedankt! mvg Jay

Leo
26-06-2010 - 17:43

Hi, Christian I too have the media panel text problem like BeSho, I posted it a long time ago, I have not tried to reflash however.

Lobke
26-06-2010 - 19:50

Hallo, Ik wil graag mijn Xperia X1 rommen, alleen het is allemaal in het engels beschreven hoe dit moet. Kan jij mij het misschien uitleggen? Ik wil ook graag hem dan rommen met jou software, maar ik weet nie hoe ik deze moet downloaden. Alvast bedankt in ieder geval! Groetjes, Lobke

Christian
27-06-2010 - 09:53

@wes: heb zelf hier nog geen last van gehad. Iets speciaals geinstalleerd?(Skin ofz?) @jay:ik zou het zelf eerlijk gezegd niet weten. Bij mij werkt het gewoon goed. Probeer eens opnieuw te installeren van marketplace @leo: don't think a reflash will work but I will look into it. Seems to be WWE only right? @lobke: kijk even in de faq in de xperia rom sectie hier staat een nederlandse handleiding van mij;)

wesjeex3
27-06-2010 - 12:29

@Christian, nee ik heb niks speciaals geinstalleerd, alleen CookiesHomeTab voor Sense, Sense had ik ook als plugin enabled.

Lobke
29-06-2010 - 00:16

Haai, Christian. Ik heb hardSPL gedownload en je rom ook, alleen ik krijg telkens de fout code: 262 Snap er echt helemaal niks van. Ik heb mijn telefoon in de modus dat je 3 gekleurde schermpjes ziet, en dan gaat die naar het grijze scherm als ik op update druk maar voor de rest doet die niks. Wat moet ik nu doen? Groetjes, Lobke

Lobke
29-06-2010 - 09:23

Hallo, Kan dit alleen worden gedaan met windows XP op je computer? Want bij mij is die binnen 1 minuut bij de 100 procent, alleen hij is niet geromd. Groetjes, Lobke

Lobke
29-06-2010 - 10:36

Het is gelukt =D Ik kreeg hem niet geromd met HARD-SPL maar die zat ook in het pakketje van jouw rom, dus heb ik het daar mee geprobeerd en het is gelukt na lang proberen.. Ik ga snel met me xperia aan de gang om te kijken hoe het bevalt! Super bedankt ieder geval al, Groetjes, Lobke

Christian
29-06-2010 - 12:06

@wes: speciaal, ik weet het eerlijk gezegd niet sorry @lobke: mooi dat het gelukt is;)

wesjeex3
30-06-2010 - 15:18

Het moet wel aan een van de dingen liggen die in deze ROM zijn toegevoegd, in 5.230 had ik het namelijk niet.

eyad
30-07-2010 - 04:17

thanks man

Catacraciun
26-08-2010 - 21:03

Hi Christian, I am using this version of your rom since you released it. it works great, but I still have a problem in Media Panel.. The text is not visible.... Can you help me? I don't want to flash my phone just for this problem. Thanx